Commit 9764b98e authored by olb's avatar olb
Browse files

Add non ajax select2 for all select (issue #167)

parent 0c6f57f3
......@@ -45,3 +45,4 @@ gem "font_awesome5_rails"
gem "cocoon"
gem 'rails-erd', group: :development
gem 'maildown'
gem 'select2-rails'
......@@ -319,6 +319,8 @@ GEM
sass-listen (4.0.0)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
select2-rails (4.0.3)
thor (~> 0.14)
selenium-webdriver (3.8.0)
childprocess (~> 0.5)
rubyzip (~> 1.0)
......@@ -401,6 +403,7 @@ DEPENDENCIES
rubocop-rspec
rubyzip (~> 1.1.6)
sass
select2-rails
selenium-webdriver
simple_form
spork-rails
......
......@@ -20,6 +20,7 @@
//= require pagy.js
//= require cocoon
//= require font_awesome5
//= require select2-full
//= require_tree .
$(document).ready(function() {
......@@ -29,3 +30,10 @@ $(document).ready(function() {
window.addEventListener("load", Pagy.init);
/* activate select2 for all select */
$(document).ready(function() {
$( "select" ).select2({
theme: "bootstrap"
});
});
......@@ -12,6 +12,8 @@
*= require_tree .
*= require bootstrap
*= require font_awesome5
*= require select2
*= require select2-bootstrap
*= stub invoice
*/
.content {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment